HVAC Site - Professional HVAC Contractors Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys, I'm new to the forum. I install HVAC for new construction but am currently having a problem with my personal furnace. I don't know a whole lot about the service side of the biz, I'm hoping I can get some help here to spare me the embarrassment of having our service guy fix it. :laughing:

I have a Lennox Elite Series, it is giving me the "Prim. Limit Open" diagnostic code. The symptoms are what is confusing me. The fan works fine when it is turned to "on" at the thermostat. But when it is set on "auto" and the heat kicks in, the fan never starts. In addition, if the fan is set to "on" and then the heat gets turned on at the thermostat the fan will shut off and then never restart. The burners are lighting just fine.

Any one having any ideas?? I appreciate any help I can get.
 

·
Registered
Joined
·
149 Posts
Is this the first time to run unit in heat mode. the prime limit is the fan limit must have tripped due to poor air flow or something. are the filters clean and are all the registers open.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Is this the first time to run unit in heat mode. the prime limit is the fan limit must have tripped due to poor air flow or something. are the filters clean and are all the registers open.
Nope, it's not the first time to run it. The furnace has been working fine this year for about a month (off and on use), it just started doing this two nights ago.

I put a new filter in, still didn't solve the problem.

I'm leaning towards a bad board or relay. Does anyone know which component would tell the fan to kick in after the burners are lit? I think that may be the problem.
 

·
North of 52
Joined
·
122 Posts
What is the complete model #. Sounds like the board is faulty. Turning the fan to ON uses a different part of the heating or cooling relay. When it calls for heat the board is programmed to stop the continuos fan (open that relay) to allow the heat exchanger to warm up and then after 90 seconds energize the heating fan relay (faulty relay on yours).
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
What is the complete model #. Sounds like the board is faulty. Turning the fan to ON uses a different part of the heating or cooling relay. When it calls for heat the board is programmed to stop the continuos fan (open that relay) to allow the heat exchanger to warm up and then after 90 seconds energize the heating fan relay (faulty relay on yours).
That sounds like the board may be the problem. Is it easy to get one of those? Or am I better off calling a service company that deals with Lennox? (We do Carrier).

Here is the furnace info

Model Number = G26Q4/5-75-3
Serial Number = 5897M32083
 

·
North of 52
Joined
·
122 Posts
Cozyparts.com has Lennox parts. 99% sure the new board is a retrofit. Follow the instructions EXACTLY and you should have no problems. Comes with an adaptor harness. Pay careful attention to the instructions as the -3 is series# 3 and you need to find the specific info for that series in the instructions.

Good Luck:thumbsup:
 

·
Registered
Joined
·
42 Posts
Is the primary or any other limits manual reset? I would check this before buying a CB

KISS - Keep It Simple...
 

·
Registered
Joined
·
8 Posts
check power on the heat speed stab on board. You should have 120 volts no longer than 20-30 seconds after burners light, Also check the heating speed wire and make sure it is ok. If you have no 120 volts then I would say its a bad board.
 
1 - 8 of 8 Posts
Top