HVAC Site - Professional HVAC Contractors Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
On a business that I take care of I swapped out a 3 1/2 ton for a 4 ton Linux all was fine had 15 superheat 18 subcooling 3 days later they were froze up found small leak fix it recharged and all was good went back a few days later on different problem after taking care of that I checked to see how the 4 ton was doing found it froze up again I check for another leak, none, put gauges on and blocked it up to get my pressure up since it was 57* that morning all looked find checked s/h and s/c running no s/h and 30-35 s/c I check air flow change out filter outdoor and indoor coil clean the filter dyer changed out not long ago I was going to put a low ambient fan control on to take care of that but with flood back I need this fixed first. This unit has a fixed orfice and I am thinking I may have noncondensable in the system? dont believe that it is overcharged or undercharge any thoughts you may have? I am running 250 high and 40* evap. 38-39* s/h 89* s/c :cry:
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Its a 4 ton coil but not a AHRI match another company had put in a new slant coil and when I got up and looked at it it was a vary old coil. I know I dont have the air flow that I need but not for from it. They wont let me put on a ambient fan control and the night is getting to cold and the unit is down under the building in a dirt corner which stays about 10* cooler. The bar is about 800 sq. feet and they have 10 or 12 registers and two main trunk lines, poorly designed
 

·
Administrator
Joined
·
966 Posts
Then let them know that if thy don't want n ambient control. that you have to charge them for coming out anytime its frozen again, as it can't work properly without one. And warranty doesn't over owner misuse, which trying to use it at low ambients without a control is owner misuse.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
I replaced the one in the kitchen with a 4 ton all is good but my other post was supposed to read I assume it is a 4 ton, the one in back is a twin to the one out front but since another company put in a old coil I cant verify that it is.When I first hooked it up I had a 10* temp glide but all checked out fine until 3 days later I thought about running a longer vacuum on it in case I had incondensable inside but no can do at this time.
 

·
Banned
Joined
·
67 Posts
Hello, If the unit is a modern unit, the first thing to do is leak check the evaporator, because 9 out of 10 times it is leaking. .
 
1 - 7 of 7 Posts
Top